summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..9444bf9
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "srce"
+version = "0.1.0"
+authors = ["SoniEx2 <endermoneymod@gmail.com>"]
+edition = "2021"
+description = "Self-Ref Cell Environments"
+license = "MIT OR Apache-2.0"
+repository = "https://soniex2.autistic.space/git-repos/srce.git"
+categories = ["no-std", "rust-patterns"]
+readme = "README.md"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+selfref = "0.4"
+qcell = {version="0.5.2", default-features=false, features=["generativity"]}
+generativity = "1.0.1"
+
+[dev-dependencies]
+selfref = {features=["alloc"]}