summary refs log tree commit diff stats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSoniEx2 <endermoneymod@gmail.com>2023-01-14 01:08:09 -0300
committerSoniEx2 <endermoneymod@gmail.com>2023-01-14 01:08:09 -0300
commit55161ce3c7a5487b0ed8597e9daa50261b549489 (patch)
tree5fc8dea2d58cdaf75d4e821a3c4724d753680c4a /Cargo.toml
[Project] Self-Ref Cell Environment
Possibly-unsound extensions to `selfref`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..9444bf9
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "srce"
+version = "0.1.0"
+authors = ["SoniEx2 <endermoneymod@gmail.com>"]
+edition = "2021"
+description = "Self-Ref Cell Environments"
+license = "MIT OR Apache-2.0"
+repository = "https://soniex2.autistic.space/git-repos/srce.git"
+categories = ["no-std", "rust-patterns"]
+readme = "README.md"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+selfref = "0.4"
+qcell = {version="0.5.2", default-features=false, features=["generativity"]}
+generativity = "1.0.1"
+
+[dev-dependencies]
+selfref = {features=["alloc"]}