summaryrefslogtreecommitdiffstats
path: root/plugins/sysinfo/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/sysinfo/meson.build')
-rw-r--r--plugins/sysinfo/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/plugins/sysinfo/meson.build b/plugins/sysinfo/meson.build
index 8b67da2e..7e2cdb6c 100644
--- a/plugins/sysinfo/meson.build
+++ b/plugins/sysinfo/meson.build
@@ -13,13 +13,13 @@ sysinfo_includes = []
sysinfo_cargs = []
system = host_machine.system()
-if system == 'linux' or system == 'gnu' or system.startswith('gnu/') or system == 'darwin'
+if system == 'linux' or system == 'gnu' or system.startswith('gnu/') or system == 'darwin' or system == 'freebsd'
sysinfo_includes += 'shared'
sysinfo_sources += [
'shared/df.c'
]
- if system == 'linux' or system == 'gnu' or system.startswith('gnu/')
+ if system == 'linux' or system == 'gnu' or system.startswith('gnu/') or system == 'freebsd'
libpci = dependency('libpci', required: false, method: 'pkg-config')
if libpci.found()
sysinfo_deps += libpci