summary refs log tree commit diff stats
path: root/plugins/lua/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/lua/Makefile.am')
-rw-r--r--plugins/lua/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/plugins/lua/Makefile.am b/plugins/lua/Makefile.am
new file mode 100644
index 00000000..b98d5f66
--- /dev/null
+++ b/plugins/lua/Makefile.am
@@ -0,0 +1,9 @@
+libdir = $(hexchatlibdir)
+
+lib_LTLIBRARIES = lua.la
+lua_la_SOURCES = lua.c
+lua_la_LDFLAGS = $(PLUGIN_LDFLAGS) -module
+lua_la_LIBADD = $(LUA_LIBS) $(GLIB_LIBS)
+lua_la_CPPFLAGS = -I$(top_srcdir)/src/common
+lua_la_CFLAGS = $(GLIB_CFLAGS) $(LUA_CFLAGS)
+