summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 5 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 21735c19..7b333fcc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,9 @@ AC_CONFIG_MACRO_DIR([m4])
 AM_INIT_AUTOMAKE([1.11 dist-bzip2 subdir-objects no-define foreign])
 AM_SILENT_RULES([yes])
 
+AX_IS_RELEASE([minor-version])
+AX_CHECK_ENABLE_DEBUG([yes])
+
 AC_USE_SYSTEM_EXTENSIONS
 AM_MAINTAINER_MODE([enable])
 AC_PROG_CC
@@ -152,10 +155,6 @@ AC_ARG_ENABLE(isocodes,
 	[AS_HELP_STRING([--disable-isocodes],[disable iso-codes with spell-check])],
         isocodes=$enableval, isocodes=yes)
 
-AC_ARG_ENABLE(minimal-flags,
-	[AS_HELP_STRING([--enable-minimal-flags],[only add those CFLAGS that are really needed or not intrusive (default: no)])],
-        minimalflags=$enableval, minimalflags=no)
-
 AC_ARG_ENABLE(static-analysis,
 	[AS_HELP_STRING([--enable-static-analysis],[if using clang run static analysis during build (default: no)])],
         analyze=$enableval, analyze=no)
@@ -611,11 +610,6 @@ dnl *********************************************************************
 dnl ** CFLAGS ***********************************************************
 dnl *********************************************************************
 
-dnl these flags might be unwanted
-if test x$minimalflags != xyes; then
-	CC_CHECK_FLAGS_APPEND([CFLAGS], [CFLAGS], [-g])
-fi
-
 CC_CHECK_FLAGS_APPEND([CFLAGS], [CFLAGS], [ \
 	-pipe \
 	-funsigned-char \
@@ -765,6 +759,8 @@ echo Do At ................. : $doat
 echo FiSHLiM ............... : $fishlim
 echo SysInfo ............... : $sysinfo
 echo
+echo Debug mode ............ : $enable_debug
+echo
 echo The binary will be installed in $prefix/bin
 echo