summary refs log tree commit diff stats
path: root/src/fe-web/meson.build
diff options
context:
space:
mode:
authorSoniEx2 <endermoneymod@gmail.com>2024-10-05 13:01:50 -0300
committerSoniEx2 <endermoneymod@gmail.com>2024-10-05 13:01:50 -0300
commit50f488236f6108bf748948c620aaf38814334a8a (patch)
tree0f5d75412f7621b4d2812dbaa646af3ba631cf5b /src/fe-web/meson.build
parente6242988ea0180e622ecd117d8a5c9fc0671494e (diff)
[WIP] fe-web: Set up basic webserver fe-web
This doesn't do anything for now.
Diffstat (limited to 'src/fe-web/meson.build')
-rw-r--r--src/fe-web/meson.build16
1 files changed, 12 insertions, 4 deletions
diff --git a/src/fe-web/meson.build b/src/fe-web/meson.build
index cc1a642b..6772eeae 100644
--- a/src/fe-web/meson.build
+++ b/src/fe-web/meson.build
@@ -1,7 +1,15 @@
+lipstixchat_web_sources = [
+  'fe-web.c'
+]
+
+libsoup_dep = dependency('libsoup-3.0')
+lipstixchat_web_deps = [
+  hexchat_common_dep,
+  libsoup_dep
+]
+
 executable('hexchat-web',
-  sources: [
-    'fe-web.c',
-  ],
-  dependencies: hexchat_common_dep,
+  sources: lipstixchat_web_sources,
+  dependencies: lipstixchat_web_deps,
   install: true,
 )