summary refs log tree commit diff stats
path: root/src/fe-text/meson.build
diff options
context:
space:
mode:
authorPatrick Griffis <tingping@tingping.se>2016-12-13 16:12:03 -0500
committerPatrick Griffis <tingping@tingping.se>2017-06-13 23:54:51 -0400
commit628100c19f5d82747170acdf2917cba8c119ccbf (patch)
tree351a7e9714a1a58390ba349808df5703cef25c3e /src/fe-text/meson.build
parent2edf50d4ddc61ce6f73bf02263c9bdd09632c66b (diff)
build: Replace Autotools with Meson
Quick rundown of benefits:

- Much faster:
  - Autotools (with autogen): 22 seconds
  - Meson: 7 seconds
  - Meson (with ccache): 2 seconds

- Simpler:
  - ~1000 lines smaller
  - Single simple language

- Potentially better Windows (Visual Studio) support

What is not done:

- Complete Windows support
- OSX support (easy)

Closes #2013
Closes #1937
Closes #1803
Diffstat (limited to 'src/fe-text/meson.build')
-rw-r--r--src/fe-text/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/fe-text/meson.build b/src/fe-text/meson.build
new file mode 100644
index 00000000..705d8852
--- /dev/null
+++ b/src/fe-text/meson.build
@@ -0,0 +1,7 @@
+executable('hexchat-text',
+  sources: [
+    'fe-text.c',
+  ],
+  dependencies: hexchat_common_dep,
+  install: true,
+)