summary refs log tree commit diff stats
path: root/src/fe-gtk/meson.build
diff options
context:
space:
mode:
authorPatrick Griffis <pgriffis@igalia.com>2021-07-13 12:24:19 -0500
committerPatrick Griffis <pgriffis@igalia.com>2021-07-13 12:26:34 -0500
commitc144d0468b5643cafd702000aee65eef8c5c1565 (patch)
tree6ef136412fddf5d3bc92c67167ff4899043beebb /src/fe-gtk/meson.build
parent482efae89ae6028e93a0934b64e618e855668f42 (diff)
Remove libnotify dependency
Instead just talk directly to the service. This fixes *sending*
a notification being blocking IO.
Diffstat (limited to 'src/fe-gtk/meson.build')
-rw-r--r--src/fe-gtk/meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/src/fe-gtk/meson.build b/src/fe-gtk/meson.build
index 020d2631..d07514db 100644
--- a/src/fe-gtk/meson.build
+++ b/src/fe-gtk/meson.build
@@ -43,11 +43,7 @@ hexchat_gtk_cflags = []
 
 hexchat_gtk_ldflags = []
 
-if libnotify_dep.found()
-  hexchat_gtk_sources += 'notifications/notification-libnotify.c'
-  hexchat_gtk_deps += libnotify_dep
-elif false # TODO HAVE_GTK_MAC
-elif host_machine.system() == 'windows'
+if host_machine.system() == 'windows'
   hexchat_gtk_sources += 'notifications/notification-windows.c'
 
   # TODO: mingw doesn't have these headers or libs
@@ -57,7 +53,7 @@ elif host_machine.system() == 'windows'
   #)
 
 else
-  hexchat_gtk_sources += 'notifications/notification-dummy.c'
+  hexchat_gtk_sources += 'notifications/notification-freedesktop.c'
 endif
 
 iso_codes = dependency('iso-codes', required: false)