summary refs log tree commit diff stats
path: root/src/fe-gtk/Makefile.am
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2015-02-04 21:38:45 -0500
committerTingPing <tingping@tingping.se>2015-02-04 21:41:10 -0500
commit75c022c49f96e9a1a8d61c847174cd6819cbc046 (patch)
tree73011ce41b92d8d743b810eaf7f7dea448a746b4 /src/fe-gtk/Makefile.am
parentf4f27e438b0791e1c0708c4f031aa80c59d965b1 (diff)
Implement OSX notification backend
Diffstat (limited to 'src/fe-gtk/Makefile.am')
-rw-r--r--src/fe-gtk/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/fe-gtk/Makefile.am b/src/fe-gtk/Makefile.am
index 28c932b1..71179853 100644
--- a/src/fe-gtk/Makefile.am
+++ b/src/fe-gtk/Makefile.am
@@ -32,8 +32,13 @@ endif
 if USE_LIBNOTIFY
 notify_c = notifications/notification-libnotify.c
 else
+if HAVE_GTK_MAC
+notify_c = notifications/notification-osx.m
+hexchat_LDFLAGS = -framework Foundation
+else
 notify_c = notifications/notification-dummy.c
 endif
+endif
 
 hexchat_SOURCES = ascii.c banlist.c chanlist.c chanview.c custom-list.c \
 	dccgui.c editlist.c fe-gtk.c fkeys.c gtkutil.c ignoregui.c joind.c menu.c \