summary refs log tree commit diff stats
path: root/meson.build
diff options
context:
space:
mode:
authorPatrick Griffis <pgriffis@igalia.com>2021-07-13 12:24:19 -0500
committerPatrick Griffis <pgriffis@igalia.com>2021-07-13 12:26:34 -0500
commitc144d0468b5643cafd702000aee65eef8c5c1565 (patch)
tree6ef136412fddf5d3bc92c67167ff4899043beebb /meson.build
parent482efae89ae6028e93a0934b64e618e855668f42 (diff)
Remove libnotify dependency
Instead just talk directly to the service. This fixes *sending*
a notification being blocking IO.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 0 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 7a29fd23..fe5f245d 100644
--- a/meson.build
+++ b/meson.build
@@ -19,7 +19,6 @@ libgmodule_dep = dependency('gmodule-2.0')
 libcanberra_dep = dependency('libcanberra', version: '>= 0.22',
                              required: get_option('libcanberra'))
 dbus_glib_dep = dependency('dbus-glib-1', required: get_option('dbus'))
-libnotify_dep = dependency('libnotify', required: get_option('libnotify'))
 
 global_deps = []
 if cc.get_id() == 'msvc'
@@ -182,7 +181,6 @@ if meson.version().version_compare('>= 0.53.0')
     'TLS (openssl)': libssl_dep.found(),
     'Plugin Support': get_option('plugin'),
     'DBus Support': dbus_glib_dep.found(),
-    'libnotify': libnotify_dep.found(),
     'libcanberra': libcanberra_dep.found(),
   }, section: 'Features')