summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Griffis <tingping@tingping.se>2016-04-05 12:18:27 -0400
committerPatrick Griffis <tingping@tingping.se>2016-04-07 18:27:37 -0700
commita3e1a287ac111db2eb636ad4ceafd211f5eeb964 (patch)
tree9aefbdcbddfe2277daf7481d6da0d64315456891 /configure.ac
parentf501e948ae30787ce1d714abb6c25b9cf83939dd (diff)
Bump glib requirement to 2.34
This is still rather old but does drop Ubuntu 12.04 support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 744c96d3..38af3a72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -190,11 +190,11 @@ dnl *********************************************************************
 dnl ** GLIB *************************************************************
 dnl *********************************************************************
 
-AM_PATH_GLIB_2_0([2.32.0], [], [AC_MSG_ERROR([Glib not found!])], [gmodule gobject gio])
+AM_PATH_GLIB_2_0([2.34.0], [], [AC_MSG_ERROR([Glib not found!])], [gmodule gobject gio])
 COMMON_CFLAGS="$GLIB_CFLAGS -DG_DISABLE_SINGLE_INCLUDES"
 COMMON_LIBS="$GLIB_LIBS"
-AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_32], [Dont warn using older APIs])
-AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [GLIB_VERSION_2_32], [Prevents using newer APIs])
+AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_34], [Dont warn using older APIs])
+AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [GLIB_VERSION_2_34], [Prevents using newer APIs])
 
 dnl *********************************************************************
 dnl ** GTK **************************************************************