summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2014-12-14 15:09:33 -0800
committerTingPing <tingping@tingping.se>2014-12-15 10:40:15 -0500
commit94568bc5179b5e04354eaf2b40d36e0c53bf9405 (patch)
tree9de564244f8bf10cd1be5b97297cabfda0805932 /configure.ac
parent226d54c90d604b5c085fe0e0206dd3f1e8decf2a (diff)
checksum: Use glib for io/checksum and misc fixes
- Fixes support for large files.
- Fixes filenames not being passed in the filename encoding.
- Drops openssl dependency.
- Code cleanup.
- Fix 'unknown command' warning.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index eeb22b53..36c20c0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -457,14 +457,8 @@ if test "$checksum" != "no"; then
 	checksum=no
 	AC_MSG_CHECKING(for plugin interface used by Checksum)
 	if test "$plugin" = yes; then
+		checksum=yes
 		AC_MSG_RESULT([yes])
-		AC_MSG_CHECKING(for OpenSSL used by Checksum)
-		if test "$openssl" = yes; then
-			checksum=yes
-			AC_MSG_RESULT([yes])
-		else
-			AC_MSG_RESULT([OpenSSL cannot be found, use the --enable-openssl option])
-		fi
 	else
 		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option])
 	fi