summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2014-01-15 13:20:15 -0500
committerTingPing <tingping@tingping.se>2014-01-15 13:20:15 -0500
commit37d92dd69ce2d8c8b825992a757c4215f1fb3809 (patch)
tree28d38df6ab54db382e167cd91e8d68ae6f4d7bc8 /configure.ac
parent8af9727937480d26ff39a7eeb96668073f846d9f (diff)
Check for gio during configure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 688ffb38..a7739ebf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -184,9 +184,10 @@ if test "$glib" = no; then
 fi
 
 PKG_CHECK_MODULES([GOBJECT], [gobject-2.0], [], [AC_MSG_ERROR(Cannot find gobject-2.0!)])
+PKG_CHECK_MODULES([GIO], [gio-2.0], [], [AC_MSG_ERROR(Cannot find gio-2.0!)])
 
-COMMON_CFLAGS="$GLIB_CFLAGS $GOBJECT_CFLAGS -DG_DISABLE_SINGLE_INCLUDES"
-COMMON_LIBS="$GLIB_LIBS $GOBJECT_LIBS -lgmodule-2.0"
+COMMON_CFLAGS="$GLIB_CFLAGS $GIO_CFLAGS $GOBJECT_CFLAGS -DG_DISABLE_SINGLE_INCLUDES"
+COMMON_LIBS="$GLIB_LIBS $GIO_LIBS $GOBJECT_LIBS -lgmodule-2.0"
 
 dnl *********************************************************************
 dnl ** GTK **************************************************************