summary refs log tree commit diff stats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSoniEx2 <endermoneymod@gmail.com>2022-06-16 22:43:18 -0300
committerSoniEx2 <endermoneymod@gmail.com>2022-06-16 22:43:18 -0300
commit890d8bbef986d8b85d6eaaddd4c8895c5f61c09c (patch)
tree20bafad4faf0689db30c1f0c1382eb1824362b8f /Cargo.toml
parentf9f0bfb13ea9e7f0b0d14887a69961657befaab2 (diff)
Migrate to edition 2021
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f2f65c2..a88a2b1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,11 +9,14 @@ homepage = "https://ganarchy.autistic.space/project/207026ae5e35da096b8110afe1ba
 keywords = ["hexchat", "plugin", "hexchat-plugin"]
 categories = ["api-bindings"]
 readme = "README.md"
+edition = "2021"
 
 [features]
 nul_in_strip = []
-nightly_tests = []
+nightly_tests = ["dep:selfref"]
 
 [dependencies]
 libc = "0.2"
 impl_trait = "0.1"
+ltptr = "0.1.1"
+selfref = { version = "0.1", optional = true }