summary refs log tree commit diff stats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSoniEx2 <endermoneymod@gmail.com>2022-07-30 11:22:23 -0300
committerSoniEx2 <endermoneymod@gmail.com>2022-07-30 11:22:23 -0300
commita8778ff35bde88bb63d9fec769edf66e68d7969e (patch)
treee9a2b7d347420e3a88f831b6f20513fcb211df4a /Cargo.toml
parentc2279c63912a47bf3078f5df3b3156ba0d9afe9f (diff)
Initial work on 0.1.0
Missing the VM.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 10 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fc15218..a0532df 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,10 +1,10 @@
 [package]
 name = "datafu"
-version = "0.0.7"
+version = "0.1.0"
 authors = ["SoniEx2 <endermoneymod@gmail.com>"]
-license = "AGPL-3.0-or-later"
+license = "MIT OR Apache-2.0"
 description = "A Rust library for extracting data from config objects and other arbitrary object graphs."
-edition = "2015"
+edition = "2021"
 repository = "https://soniex2.autistic.space/git-repos/dfu.git"
 readme = "README.md"
 homepage = "https://soniex2.github.io/ganarchy/project/c0b4a8a326a320ac33c5d9d6bac2f7ea7eb703ce/"
@@ -13,14 +13,15 @@ homepage = "https://soniex2.github.io/ganarchy/project/c0b4a8a326a320ac33c5d9d6b
 
 [dependencies]
 regex = "1"
-impl_trait = "0.1.2"
-
-[target.'cfg(target_os = "linux")'.dependencies]
-totally-safe-transmute = "0.0.3"
+impl_trait = "0.1.7"
+serde = "1.0.140"
+erased-serde = "0.3.21"
 
 [dev-dependencies]
-proptest = "0.10.1"
+proptest = "1.0.0"
+serde_json = "1.0.82"
+serde = {version = "1.0.140", features = ["derive"]}
 
 [features]
-default = []
+default = ['stable']
 stable = []