summary refs log tree commit diff stats
path: root/libotr/libgpg-error-1.42/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libotr/libgpg-error-1.42/tests/Makefile.am')
-rw-r--r--libotr/libgpg-error-1.42/tests/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/libotr/libgpg-error-1.42/tests/Makefile.am b/libotr/libgpg-error-1.42/tests/Makefile.am
new file mode 100644
index 0000000..be04df3
--- /dev/null
+++ b/libotr/libgpg-error-1.42/tests/Makefile.am
@@ -0,0 +1,44 @@
+# Makefile.am for libgpg-error/tests.
+# Copyright (C) 2003 g10 Code GmbH
+#
+# This file is part of libgpg-error.
+#
+# libgpg-error is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2.1 of the
+# License, or (at your option) any later version.
+#
+# libgpg-error is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+
+## Process this file with automake to produce Makefile.in
+
+if HAVE_W32CE_SYSTEM
+extra_includes = -idirafter $(top_builddir)/src/gpg-extra
+else
+extra_includes =
+endif
+
+EXTRA_DIST = t-argparse.conf etc/t-argparse.conf
+
+gpg_error_lib = ../src/libgpg-error.la
+
+TESTS = t-version t-strerror t-syserror t-lock t-printf t-poll t-b64 \
+	t-argparse t-logging t-stringutils t-malloc
+
+AM_CPPFLAGS = -I$(top_builddir)/src $(extra_includes)
+
+AM_LDFLAGS = -no-install
+LDADD = $(gpg_error_lib) @LDADD_FOR_TESTS_KLUDGE@
+
+noinst_PROGRAMS = $(TESTS)
+noinst_HEADERS = t-common.h
+
+t_lock_LDADD = $(LDADD) $(LIBMULTITHREAD)
+t_poll_LDADD = $(LDADD) $(LIBMULTITHREAD)