summary refs log tree commit diff stats
path: root/libotr/libotr-4.1.1/tests/regression/client/Makefile.am
diff options
context:
space:
mode:
authorSoniEx2 <endermoneymod@gmail.com>2021-04-09 07:19:03 -0300
committerSoniEx2 <endermoneymod@gmail.com>2021-04-09 07:19:03 -0300
commit0e752a6e215aee21dc73da097c3225495d54a5b6 (patch)
treeb81be02cbf2f06aebf322ac4a5d014b44176bba5 /libotr/libotr-4.1.1/tests/regression/client/Makefile.am
parent7754076c715285173311a1b6811ce377950e18a6 (diff)
Add libotr/etc sources
Diffstat (limited to 'libotr/libotr-4.1.1/tests/regression/client/Makefile.am')
-rw-r--r--libotr/libotr-4.1.1/tests/regression/client/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/libotr/libotr-4.1.1/tests/regression/client/Makefile.am b/libotr/libotr-4.1.1/tests/regression/client/Makefile.am
new file mode 100644
index 0000000..d2b11be
--- /dev/null
+++ b/libotr/libotr-4.1.1/tests/regression/client/Makefile.am
@@ -0,0 +1,16 @@
+AM_CFLAGS = -I$(top_srcdir)/include \
+			-I$(top_srcdir)/src \
+			-I$(top_srcdir)/tests/utils/ \
+			-I$(srcdir) \
+			@LIBGCRYPT_CFLAGS@
+
+LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
+
+LIBOTR=$(top_builddir)/src/libotr.la
+
+noinst_PROGRAMS = client
+
+client_SOURCES = client.c
+client_LDADD = $(LIBTAP) $(LIBOTR) -lpthread @LIBGCRYPT_LIBS@
+
+EXTRA_DIST = otr.key