summary refs log tree commit diff stats
path: root/libotr/libotr-4.1.1/src/Makefile.am
diff options
context:
space:
mode:
authorSoniEx2 <endermoneymod@gmail.com>2021-04-09 07:19:03 -0300
committerSoniEx2 <endermoneymod@gmail.com>2021-04-09 07:19:03 -0300
commit0e752a6e215aee21dc73da097c3225495d54a5b6 (patch)
treeb81be02cbf2f06aebf322ac4a5d014b44176bba5 /libotr/libotr-4.1.1/src/Makefile.am
parent7754076c715285173311a1b6811ce377950e18a6 (diff)
Add libotr/etc sources
Diffstat (limited to 'libotr/libotr-4.1.1/src/Makefile.am')
-rw-r--r--libotr/libotr-4.1.1/src/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/libotr/libotr-4.1.1/src/Makefile.am b/libotr/libotr-4.1.1/src/Makefile.am
new file mode 100644
index 0000000..c2146cf
--- /dev/null
+++ b/libotr/libotr-4.1.1/src/Makefile.am
@@ -0,0 +1,14 @@
+AM_CPPFLAGS = @LIBGCRYPT_CFLAGS@
+
+lib_LTLIBRARIES = libotr.la
+
+libotr_la_SOURCES = privkey.c context.c proto.c b64.c dh.c mem.c message.c \
+		    userstate.c tlv.c auth.c sm.c context_priv.c instag.c
+
+libotr_la_LDFLAGS = -version-info @LIBOTR_LIBTOOL_VERSION@ @LIBS@ @LIBGCRYPT_LIBS@
+
+otrincdir = $(includedir)/libotr
+
+otrinc_HEADERS = b64.h context.h dh.h mem.h message.h privkey.h proto.h \
+		 version.h userstate.h tlv.h serial.h auth.h sm.h privkey-t.h \
+		 context_priv.h instag.h