summary refs log tree commit diff stats
path: root/src/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/meson.build')
-rw-r--r--src/common/meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/common/meson.build b/src/common/meson.build
index a0d6ce2b..492227b2 100644
--- a/src/common/meson.build
+++ b/src/common/meson.build
@@ -93,10 +93,6 @@ endif
 
 if get_option('with-plugin')
   common_deps += libgmodule_dep
-  common_cflags += '-DHEXCHATLIBDIR="@0@"'.format(join_paths(get_option('prefix'),
-                                                  get_option('libdir'),
-                                                  'hexchat/plugins'))
-
   install_headers('hexchat-plugin.h')
 endif
 
@@ -109,6 +105,7 @@ hexchat_common = static_library('hexchatcommon',
 )
 
 hexchat_common_dep = declare_dependency(
+  sources: [textevents] + marshal,
   link_with: hexchat_common,
   include_directories: common_includes,
   compile_args: common_cflags,