summary refs log tree commit diff stats
path: root/src/common/dbus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/dbus/Makefile.am')
-rw-r--r--src/common/dbus/Makefile.am7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/common/dbus/Makefile.am b/src/common/dbus/Makefile.am
index bad6f611..4fa30452 100644
--- a/src/common/dbus/Makefile.am
+++ b/src/common/dbus/Makefile.am
@@ -7,12 +7,10 @@ libhexchatdbus_a_SOURCES =			\
 
 EXTRA_DIST =				\
 	remote-object.xml		\
-	marshallers.list		\
 	example.py			\
 	org.hexchat.service.service.in
 
 BUILT_SOURCES =				\
-	marshallers.h			\
 	remote-object-glue.h
 
 CLEANFILES = $(BUILT_SOURCES)
@@ -20,15 +18,12 @@ CLEANFILES = $(BUILT_SOURCES)
 AM_CPPFLAGS = $(COMMON_CFLAGS) $(DBUS_CFLAGS)
 
 noinst_PROGRAMS = example
-example_SOURCES = example.c 
+example_SOURCES = example.c
 example_LDADD = $(DBUS_LIBS) $(GLIB_LIBS)
 
 remote-object-glue.h: remote-object.xml
 	$(AM_V_GEN) $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=remote_object --mode=glib-server --output=$@ $<
 
-marshallers.h: marshallers.list
-	$(AM_V_GEN) $(LIBTOOL) --mode=execute $(GLIB_GENMARSHAL)  --header --body $< > $@
-
 # Dbus service file
 servicedir = $(DBUS_SERVICES_DIR)
 service_in_files = org.hexchat.service.service.in