summary refs log tree commit diff stats
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index ca1eaba3..9c2d443e 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -44,6 +44,10 @@ if USE_OPENSSL
 ssl_c = ssl.c
 endif
 
+if USE_MSPROXY
+msproxy_c = msproxy.c
+endif
+
 if USE_DBUS
 dbusdir = dbus
 libhexchatcommon_a_LIBADD =				\
@@ -58,7 +62,7 @@ endif
 noinst_PROGRAMS = make-te
 
 libhexchatcommon_a_SOURCES = cfgfiles.c chanopt.c ctcp.c dcc.c hexchat.c \
-	history.c ignore.c inbound.c modes.c msproxy.c network.c notify.c \
+	history.c ignore.c inbound.c modes.c $(msproxy_c) network.c notify.c \
 	outbound.c plugin.c plugin-timer.c proto-irc.c server.c servlist.c \
 	$(ssl_c) text.c tree.c url.c userlist.c util.c
 libhexchatcommon_a_CFLAGS = $(LIBPROXY_CFLAGS)