summary refs log tree commit diff stats
path: root/plugins/sysinfo/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/sysinfo/meson.build')
-rw-r--r--plugins/sysinfo/meson.build46
1 files changed, 46 insertions, 0 deletions
diff --git a/plugins/sysinfo/meson.build b/plugins/sysinfo/meson.build
new file mode 100644
index 00000000..2bee3e76
--- /dev/null
+++ b/plugins/sysinfo/meson.build
@@ -0,0 +1,46 @@
+sysinfo_sources = [
+  'format.c',
+  'sysinfo.c',
+]
+
+sysinfo_deps = [
+  libgio_dep,
+  hexchat_plugin_dep
+]
+
+sysinfo_includes = []
+
+system = host_machine.system()
+if system == 'linux' or system == 'darwin'
+  sysinfo_includes += 'shared'
+  sysinfo_sources += [
+    'shared/df.c'
+  ]
+
+  if system == 'linux'
+    sysinfo_deps += dependency('libpci')
+    sysinfo_includes += 'unix'
+    sysinfo_sources += [
+      'unix/backend.c',
+      'unix/match.c',
+      'unix/parse.c',
+      'unix/pci.c',
+    ]
+  elif system == 'darwin'
+    add_languages('objc')
+    sysinfo_sources += 'osx/backend.m'
+  endif
+
+elif system == 'windows'
+  sysinfo_sources += 'win32/backend.c'
+else
+  error('sysinfo: Unknown system?')
+endif
+
+shared_module('sysinfo', sysinfo_sources,
+  dependencies: sysinfo_deps,
+  include_directories: include_directories(sysinfo_includes),
+  install: true,
+  install_dir: plugindir,
+  name_prefix: '',
+)
\ No newline at end of file