summary refs log tree commit diff stats
path: root/plugins/perl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/perl/meson.build')
-rw-r--r--plugins/perl/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins/perl/meson.build b/plugins/perl/meson.build
index 180797ee..3779a35c 100644
--- a/plugins/perl/meson.build
+++ b/plugins/perl/meson.build
@@ -25,7 +25,7 @@ if get_option('with-perl-legacy-api')
   perl_cflags += '-DOLD_PERL'
 endif
 
-perl = find_program('perl')
+perl = find_program(get_option('with-perl'))
 
 ret = run_command([perl, '-MExtUtils::Embed', '-e', 'ccopts'])
 if ret.returncode() != 0