summary refs log tree commit diff stats
path: root/plugins/mailcheck/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/mailcheck/Makefile.am')
-rw-r--r--plugins/mailcheck/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/plugins/mailcheck/Makefile.am b/plugins/mailcheck/Makefile.am
new file mode 100644
index 00000000..bda04229
--- /dev/null
+++ b/plugins/mailcheck/Makefile.am
@@ -0,0 +1,25 @@
+## Process with automake to produce Makefile.in
+
+# To create a standalone tarball of your plugin run the plugin_dist
+# target.  Note: you must configure the main source tree with
+# --enable-maintainer-mode
+
+# These two must be defined.
+PLUGIN=mailcheck
+PLUGIN_VERSION=0.1
+
+# This file must be in the form PLUGIN-config.h.in, it can be empty but
+# must exist
+EXTRA_DIST = mailcheck-config.h.in
+
+# Remember to include this line in your Makefile.am
+include @top_srcdir@/plugins/Make.plugin
+
+libdir = $(xchatdir)/plugins
+
+lib_LTLIBRARIES = mailcheck.la
+mailcheck_la_SOURCES = mailcheck.c
+mailcheck_la_LDFLAGS = -avoid-version -module 
+INCLUDES = $(COMMON_CFLAGS) $(PLUGIN_INCLUDES)
+
+DISTCLEANFILES = pg_dir/*