summary refs log tree commit diff stats
path: root/plugins/lua/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/lua/meson.build')
-rw-r--r--plugins/lua/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/plugins/lua/meson.build b/plugins/lua/meson.build
new file mode 100644
index 00000000..7faa3054
--- /dev/null
+++ b/plugins/lua/meson.build
@@ -0,0 +1,12 @@
+if cc.get_id() == 'msvc'
+  lua_dep = cc.find_library('lua51')
+else
+  lua_dep = dependency(get_option('with-lua'))
+endif
+
+shared_module('lua', 'lua.c',
+  dependencies: [libgio_dep, hexchat_plugin_dep, lua_dep],
+  install: true,
+  install_dir: plugindir,
+  name_prefix: '',
+)