summary refs log tree commit diff stats
path: root/data/misc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'data/misc/meson.build')
-rw-r--r--data/misc/meson.build28
1 files changed, 15 insertions, 13 deletions
diff --git a/data/misc/meson.build b/data/misc/meson.build
index 02d6bf25..f7f1c27f 100644
--- a/data/misc/meson.build
+++ b/data/misc/meson.build
@@ -3,19 +3,21 @@ metainfodir = join_paths(get_option('datadir'), 'metainfo')
 desktop_utils = find_program('desktop-file-validate', required: false)
 
 if get_option('with-gtk')
-  hexchat_appdata = i18n.merge_file(
-    input: 'io.github.Hexchat.appdata.xml.in',
-    output: 'io.github.Hexchat.appdata.xml',
-    po_dir: '../../po',
-    install: true,
-    install_dir: metainfodir
-  )
-
-  appstream_util = find_program('appstream-util', required: false)
-  if appstream_util.found()
-    test('Validate io.github.Hexchat.appdata.xml', appstream_util,
-      args: ['validate-relax', hexchat_appdata]
+  if get_option('with-appdata')
+    hexchat_appdata = i18n.merge_file(
+      input: 'io.github.Hexchat.appdata.xml.in',
+      output: 'io.github.Hexchat.appdata.xml',
+      po_dir: '../../po',
+      install: true,
+      install_dir: metainfodir
     )
+
+    appstream_util = find_program('appstream-util', required: false)
+    if appstream_util.found()
+      test('Validate io.github.Hexchat.appdata.xml', appstream_util,
+        args: ['validate-relax', hexchat_appdata]
+      )
+    endif
   endif
 
   desktop_conf = configuration_data()
@@ -68,7 +70,7 @@ if get_option('with-theme-manager')
   )
 endif
 
-if get_option('with-plugin')
+if get_option('with-plugin') and get_option('with-appdata')
   plugin_metainfo = []
 
   # FIXME: These should all get translated somewhere