summary refs log tree commit diff stats
path: root/data/man/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'data/man/meson.build')
-rw-r--r--data/man/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/data/man/meson.build b/data/man/meson.build
new file mode 100644
index 00000000..8f07f558
--- /dev/null
+++ b/data/man/meson.build
@@ -0,0 +1,10 @@
+man_conf = configuration_data()
+man_conf.set('VERSION', meson.project_version())
+
+configure_file(
+  input: 'hexchat.1.in',
+  output: 'hexchat.1',
+  configuration: man_conf,
+  install: true,
+  install_dir: join_paths(get_option('mandir'), 'man1')
+)