summary refs log tree commit diff stats
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
new file mode 100644
index 00000000..06e52ad5
--- /dev/null
+++ b/data/icons/Makefile.am
@@ -0,0 +1,13 @@
+icon_DATA = hexchat.png
+icondir = $(datadir)/icons/hicolor/48x48/apps
+
+hicolor_DATA = hexchat.svg
+hicolordir = $(datadir)/icons/hicolor/scalable/apps
+
+UPDATE_ICON_CACHE = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor || :
+
+install-data-hook:
+	$(UPDATE_ICON_CACHE);
+
+uninstall-hook:
+	$(UPDATE_ICON_CACHE);