summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in168
1 files changed, 116 insertions, 52 deletions
diff --git a/configure.in b/configure.in
index 34f83f3d..c8b21be6 100644
--- a/configure.in
+++ b/configure.in
@@ -129,17 +129,25 @@ AC_ARG_ENABLE(tcl,
 [  --enable-tcl[=PATH]       directory with Tcl config file: tclConfig.sh],
         tcl=$enableval, tcl=yes)
 
-AC_ARG_ENABLE(sasl,
-[  --disable-sasl          disable the SASL plugin],
-        sasl=$enableval, sasl=yes)
+AC_ARG_ENABLE(plugin,
+[  --disable-plugin        disable plugin support],
+        plugin=$enableval, plugin=yes)
+
+AC_ARG_ENABLE(checksum,
+[  --disable-checksum      disable the Checksum plugin],
+        checksum=$enableval, checksum=yes)
 
 AC_ARG_ENABLE(doat,
 [  --disable-doat          disable the Do At plugin],
         doat=$enableval, doat=yes)
 
-AC_ARG_ENABLE(plugin,
-[  --disable-plugin        disable plugin support],
-        plugin=$enableval, plugin=yes)
+AC_ARG_ENABLE(fishlim,
+[  --disable-fishlim       disable the FiSHLiM plugin],
+        fishlim=$enableval, fishlim=yes)
+
+AC_ARG_ENABLE(sasl,
+[  --disable-sasl          disable the SASL plugin],
+        sasl=$enableval, sasl=yes)
 
 AC_ARG_ENABLE(dbus,
 [  --disable-dbus          disable DBUS support],
@@ -371,36 +379,6 @@ if test "$tcl" != "no"; then
 fi
 
 dnl *********************************************************************
-dnl ** SASL *************************************************************
-dnl *********************************************************************
-
-if test "$sasl" != "no"; then
-AC_MSG_CHECKING(for plugin interface used by SASL)
-	sasl=no
-	if test "$plugin" = yes; then
-		sasl=yes
-		AC_MSG_RESULT([yes])
-	else
-		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option for SASL])
-	fi
-fi
-
-dnl *********************************************************************
-dnl ** DO AT ************************************************************
-dnl *********************************************************************
-
-if test "$doat" != "no"; then
-AC_MSG_CHECKING(for plugin interface used by Do At)
-	doat=no
-	if test "$plugin" = yes; then
-		doat=yes
-		AC_MSG_RESULT([yes])
-	else
-		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option for Do At])
-	fi
-fi
-
-dnl *********************************************************************
 dnl ** IPv6 *************************************************************
 dnl *********************************************************************
 
@@ -521,6 +499,78 @@ if test "$plugin" = yes; then
 	fi
 fi
 
+dnl *********************************************************************
+dnl ** Checksum *********************************************************
+dnl *********************************************************************
+
+if test "$checksum" != "no"; then
+	checksum=no
+	AC_MSG_CHECKING(for plugin interface used by Checksum)
+	if test "$plugin" = yes; then
+		AC_MSG_RESULT([yes])
+		AC_MSG_CHECKING(for OpenSSL used by Checksum)
+		if test "$openssl" = yes; then
+			checksum=yes
+			AC_MSG_RESULT([yes])
+		else
+			AC_MSG_RESULT([OpenSSL cannot be found, use the --enable-openssl option])
+		fi
+	else
+		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option])
+	fi
+fi
+
+dnl *********************************************************************
+dnl ** DO AT ************************************************************
+dnl *********************************************************************
+
+if test "$doat" != "no"; then
+	AC_MSG_CHECKING(for plugin interface used by Do At)
+	doat=no
+	if test "$plugin" = yes; then
+		doat=yes
+		AC_MSG_RESULT([yes])
+	else
+		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option for Do At])
+	fi
+fi
+
+dnl *********************************************************************
+dnl ** FiSHLiM **********************************************************
+dnl *********************************************************************
+
+if test "$fishlim" != "no"; then
+	fishlim=no
+	AC_MSG_CHECKING(for plugin interface used by FiSHLiM)
+	if test "$plugin" = yes; then
+		AC_MSG_RESULT([yes])
+		AC_MSG_CHECKING(for OpenSSL used by FiSHLiM)
+		if test "$openssl" = yes; then
+			fishlim=yes
+			AC_MSG_RESULT([yes])
+		else
+			AC_MSG_RESULT([OpenSSL cannot be found, use the --enable-openssl option])
+		fi
+	else
+		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option])
+	fi
+fi
+
+dnl *********************************************************************
+dnl ** SASL *************************************************************
+dnl *********************************************************************
+
+if test "$sasl" != "no"; then
+	AC_MSG_CHECKING(for plugin interface used by SASL)
+	sasl=no
+	if test "$plugin" = yes; then
+		sasl=yes
+		AC_MSG_RESULT([yes])
+	else
+		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option for SASL])
+	fi
+fi
+
 dnl #######################################################################
 dnl # Check for DBUS libraries
 dnl #######################################################################
@@ -613,9 +663,11 @@ AM_CONDITIONAL(DO_GTK, test "x$gtkfe" = "xyes")
 AM_CONDITIONAL(DO_PERL, test "x$perl" = "xyes")
 AM_CONDITIONAL(DO_PYTHON, test "x$python" = "xyes")
 AM_CONDITIONAL(DO_TCL, test "x$tcl" = "xyes")
-AM_CONDITIONAL(DO_SASL, test "x$sasl" = "xyes")
-AM_CONDITIONAL(DO_DOAT, test "x$doat" = "xyes")
 AM_CONDITIONAL(DO_PLUGIN, test "x$plugin" = "xyes")
+AM_CONDITIONAL(DO_CHECKSUM, test "x$checksum" = "xyes")
+AM_CONDITIONAL(DO_DOAT, test "x$doat" = "xyes")
+AM_CONDITIONAL(DO_FISHLIM, test "x$fishlim" = "xyes")
+AM_CONDITIONAL(DO_SASL, test "x$sasl" = "xyes")
 AM_CONDITIONAL(USE_DBUS, test "x$dbus" = "xyes")
 AM_CONDITIONAL(DO_GCONF, test "x$GCONFTOOL" != "xno")
 
@@ -877,8 +929,10 @@ plugins/Makefile
 plugins/python/Makefile
 plugins/perl/Makefile
 plugins/tcl/Makefile
-plugins/sasl/Makefile
+plugins/checksum/Makefile
 plugins/doat/Makefile
+plugins/fishlim/Makefile
+plugins/sasl/Makefile
 intl/Makefile
 po/Makefile.in
 ])
@@ -886,23 +940,33 @@ po/Makefile.in
 echo
 echo HexChat $VERSION
 echo
-echo Building GTK+ Interface .... : $gtkfe
-echo Building TEXT Interface .... : $textfe
+echo GTK+ interface ........ : $gtkfe
+echo Text interface ........ : $textfe
 echo
-echo mmx tinting ......... : $mmx\	spelling .............. : $spell
-echo XShm tinting ........ : $shm\	plugin interface ...... : $plugin
+echo MMX tinting ........... : $mmx
+echo XShm tinting .......... : $shm
 if test "$xft" = no; then
-  echo text backend ........ : pango\	nls/gettext ........... : $USE_NLS
+  echo Text backend .......... : Pango
 else
-  echo text backend ........ : xft\	nls/gettext ........... : $USE_NLS
-fi
-echo openssl support ..... : $openssl\	ipv6 support .......... : $ipv6
-echo dbus support ........ : $dbus\	msproxy ntlm \(ISA\) .... : $have_ntlm
-echo libnotify support ... : $libnotify
+  echo Text backend .......... : Xft
+fi
+echo OpenSSL support ....... : $openssl
+echo D-Bus support ......... : $dbus
+echo libnotify support ..... : $libnotify
+echo Spelling .............. : $spell
+echo Plugin interface ...... : $plugin
+echo NLS/gettext ........... : $USE_NLS
+echo IPv6 support .......... : $ipv6
+echo MS Proxy NTLM \(ISA\) ... : $have_ntlm
+echo
+echo Perl .................. : $perl
+echo Python ................ : $python
+echo Tcl ................... : $tcl
 echo
-echo Perl ................ : $perl\	SASL .................. : $sasl
-echo Python .............. : $python\	Do At ................. : $doat
-echo Tcl ................. : $tcl
+echo Checksum .............. : $checksum
+echo Do At ................. : $doat
+echo FiSHLiM ............... : $fishlim
+echo SASL .................. : $sasl
 echo
 echo The binary will be installed in $prefix/bin
 echo