summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 26 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index a65823fa..6c5e60b6 100644
--- a/configure.in
+++ b/configure.in
@@ -129,6 +129,10 @@ AC_ARG_ENABLE(tcl,
 [  --enable-tcl[=PATH]       directory with Tcl config file: tclConfig.sh],
         tcl=$enableval, tcl=yes)
 
+AC_ARG_ENABLE(sasl,
+[  --disable-sasl           disable the SASL plugin],
+        sasl=$enableval, sasl=yes)
+
 AC_ARG_ENABLE(plugin,
 [  --disable-plugin        disable plugin support],
         plugin=$enableval, plugin=yes)
@@ -363,6 +367,21 @@ if test "$tcl" != "no"; then
 fi
 
 dnl *********************************************************************
+dnl ** SASL *************************************************************
+dnl *********************************************************************
+
+if test "$sasl" != "no"; then
+AC_MSG_CHECKING(for plugin interface used by SASL)
+	sasl=no
+	if test "$plugin" = yes; then
+		sasl=yes
+		AC_MSG_RESULT([yes])
+	else
+		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option for SASL])
+	fi
+fi
+
+dnl *********************************************************************
 dnl ** IPv6 *************************************************************
 dnl *********************************************************************
 
@@ -575,6 +594,7 @@ AM_CONDITIONAL(DO_GTK, test "x$gtkfe" = "xyes")
 AM_CONDITIONAL(DO_PERL, test "x$perl" = "xyes")
 AM_CONDITIONAL(DO_PYTHON, test "x$python" = "xyes")
 AM_CONDITIONAL(DO_TCL, test "x$tcl" = "xyes")
+AM_CONDITIONAL(DO_SASL, test "x$sasl" = "xyes")
 AM_CONDITIONAL(DO_PLUGIN, test "x$plugin" = "xyes")
 AM_CONDITIONAL(USE_DBUS, test "x$dbus" = "xyes")
 AM_CONDITIONAL(DO_GCONF, test "x$GCONFTOOL" != "xno")
@@ -837,18 +857,17 @@ plugins/Makefile
 plugins/python/Makefile
 plugins/perl/Makefile
 plugins/tcl/Makefile
+plugins/sasl/Makefile
 intl/Makefile
 po/Makefile.in
 ])
 
 echo
-echo hexchat $VERSION
+echo HexChat $VERSION
 echo
 echo Building GTK+ Interface .... : $gtkfe
 echo Building TEXT Interface .... : $textfe
 echo
-echo PLUGINS: Perl: $perl Python: $python TCL: $tcl
-echo
 echo mmx tinting ......... : $mmx\	spelling .............. : $spell
 echo XShm tinting ........ : $shm\	plugin interface ...... : $plugin
 if test "$xft" = no; then
@@ -860,6 +879,10 @@ echo openssl support ..... : $openssl\	ipv6 support .......... : $ipv6
 echo dbus support ........ : $dbus\	msproxy ntlm \(ISA\) .... : $have_ntlm
 echo libnotify support ... : $libnotify
 echo
+echo Perl ................ : $perl\	SASL .................. : $sasl
+echo Python .............. : $python
+echo Tcl ................. : $tcl
+echo
 echo The binary will be installed in $prefix/bin
 echo