summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in89
1 files changed, 58 insertions, 31 deletions
diff --git a/configure.in b/configure.in
index 34f83f3d..2a041a7d 100644
--- a/configure.in
+++ b/configure.in
@@ -137,6 +137,10 @@ AC_ARG_ENABLE(doat,
 [  --disable-doat          disable the Do At plugin],
         doat=$enableval, doat=yes)
 
+AC_ARG_ENABLE(fishlim,
+[  --disable-fishlim       disable the FiSHLiM plugin],
+        fishlim=$enableval, fishlim=yes)
+
 AC_ARG_ENABLE(plugin,
 [  --disable-plugin        disable plugin support],
         plugin=$enableval, plugin=yes)
@@ -371,36 +375,6 @@ if test "$tcl" != "no"; then
 fi
 
 dnl *********************************************************************
-dnl ** SASL *************************************************************
-dnl *********************************************************************
-
-if test "$sasl" != "no"; then
-AC_MSG_CHECKING(for plugin interface used by SASL)
-	sasl=no
-	if test "$plugin" = yes; then
-		sasl=yes
-		AC_MSG_RESULT([yes])
-	else
-		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option for SASL])
-	fi
-fi
-
-dnl *********************************************************************
-dnl ** DO AT ************************************************************
-dnl *********************************************************************
-
-if test "$doat" != "no"; then
-AC_MSG_CHECKING(for plugin interface used by Do At)
-	doat=no
-	if test "$plugin" = yes; then
-		doat=yes
-		AC_MSG_RESULT([yes])
-	else
-		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option for Do At])
-	fi
-fi
-
-dnl *********************************************************************
 dnl ** IPv6 *************************************************************
 dnl *********************************************************************
 
@@ -521,6 +495,57 @@ if test "$plugin" = yes; then
 	fi
 fi
 
+dnl *********************************************************************
+dnl ** SASL *************************************************************
+dnl *********************************************************************
+
+if test "$sasl" != "no"; then
+	AC_MSG_CHECKING(for plugin interface used by SASL)
+	sasl=no
+	if test "$plugin" = yes; then
+		sasl=yes
+		AC_MSG_RESULT([yes])
+	else
+		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option for SASL])
+	fi
+fi
+
+dnl *********************************************************************
+dnl ** DO AT ************************************************************
+dnl *********************************************************************
+
+if test "$doat" != "no"; then
+	AC_MSG_CHECKING(for plugin interface used by Do At)
+	doat=no
+	if test "$plugin" = yes; then
+		doat=yes
+		AC_MSG_RESULT([yes])
+	else
+		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option for Do At])
+	fi
+fi
+
+dnl *********************************************************************
+dnl ** FiSHLiM **********************************************************
+dnl *********************************************************************
+
+if test "$fishlim" != "no"; then
+	fishlim=no
+	AC_MSG_CHECKING(for plugin interface used by FiSHLiM)
+	if test "$plugin" = yes; then
+		AC_MSG_RESULT([yes])
+	else
+		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option])
+	fi
+	AC_MSG_CHECKING(for OpenSSL used by FiSHLiM)
+	if test "$openssl" = yes; then
+		fishlim=yes
+		AC_MSG_RESULT([yes])
+	else
+		AC_MSG_RESULT([OpenSSL cannot be found, use the --enable-openssl option])
+	fi
+fi
+
 dnl #######################################################################
 dnl # Check for DBUS libraries
 dnl #######################################################################
@@ -615,6 +640,7 @@ AM_CONDITIONAL(DO_PYTHON, test "x$python" = "xyes")
 AM_CONDITIONAL(DO_TCL, test "x$tcl" = "xyes")
 AM_CONDITIONAL(DO_SASL, test "x$sasl" = "xyes")
 AM_CONDITIONAL(DO_DOAT, test "x$doat" = "xyes")
+AM_CONDITIONAL(DO_FISHLIM, test "x$fishlim" = "xyes")
 AM_CONDITIONAL(DO_PLUGIN, test "x$plugin" = "xyes")
 AM_CONDITIONAL(USE_DBUS, test "x$dbus" = "xyes")
 AM_CONDITIONAL(DO_GCONF, test "x$GCONFTOOL" != "xno")
@@ -879,6 +905,7 @@ plugins/perl/Makefile
 plugins/tcl/Makefile
 plugins/sasl/Makefile
 plugins/doat/Makefile
+plugins/fishlim/Makefile
 intl/Makefile
 po/Makefile.in
 ])
@@ -902,7 +929,7 @@ echo libnotify support ... : $libnotify
 echo
 echo Perl ................ : $perl\	SASL .................. : $sasl
 echo Python .............. : $python\	Do At ................. : $doat
-echo Tcl ................. : $tcl
+echo Tcl ................. : $tcl\	FiSHLiM ............... : $fishlim
 echo
 echo The binary will be installed in $prefix/bin
 echo