summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 14 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 0ff129b0..ccede768 100644
--- a/configure.ac
+++ b/configure.ac
@@ -293,25 +293,31 @@ if test "x$python" != xno ; then
 		case $python in
 			dnl set python2 default here
 			python2)
-				PKG_CHECK_MODULES([PY], [python-2.7], [], [AC_MSG_ERROR(Cannot find python-2.7!)])
+				PKG_CHECK_MODULES([PY], [python-2.7], [], [AC_MSG_WARN(Cannot find python-2.7!)])
 				PY_VER="`$PKG_CONFIG --modversion python-2.7`";;
 			dnl set python3 default here
 			python3)
-				PKG_CHECK_MODULES([PY], [python-3.3], [], [AC_MSG_ERROR(Cannot find python-3.3!)])
+				PKG_CHECK_MODULES([PY], [python-3.3], [], [AC_MSG_WARN(Cannot find python-3.3!)])
 				PY_VER="`$PKG_CONFIG --modversion python-3.3`";;
 			dnl add broken versions here
 			python2.5|python2.6|python3.1|python3.2)
 				AC_MSG_ERROR(Unsupported Python version ${python}!);;
 			python*)
 				python="python-${python#python}" # stay posix compliant
-				PKG_CHECK_MODULES([PY], [${python}], [], [AC_MSG_ERROR(Cannot find "${python}.pc"!)])
+				PKG_CHECK_MODULES([PY], [${python}], [], [AC_MSG_WARN(Cannot find "${python}.pc"!)])
 				PY_VER="`$PKG_CONFIG --modversion ${python}`";;
 			*)
-				AC_MSG_ERROR(Unsupported Python ${python}!)
+				AC_MSG_WARN(Unsupported Python ${python}!)
 		esac
 		AC_MSG_CHECKING(Python version)
-		AC_MSG_RESULT($PY_VER)
-		python="python-${PY_VER}"
+
+		if test "$PY_VER"; then
+			AC_MSG_RESULT($PY_VER)
+			python="python-${PY_VER}"
+		else
+			AC_MSG_RESULT(Not found)
+			python=no
+		fi
 	else
 		AC_MSG_RESULT([plugins are disabled, use the --enable-plugin option for Python])
 		python=no
@@ -594,6 +600,7 @@ dnl *********************************************************************
 AM_CONDITIONAL(USE_OPENSSL, test "x$openssl" = "xyes")
 AM_CONDITIONAL(USE_LIBNOTIFY, test "x$libnotify" = "xyes")
 AM_CONDITIONAL(USE_LIBCANBERRA, test "x$libcanberra" = "xyes")
+AM_CONDITIONAL(USE_MSPROXY, test "x$ntlm" = "xyes")
 AM_CONDITIONAL(DO_TEXT, test "x$textfe" = "xyes")
 AM_CONDITIONAL(DO_GTK, test "x$gtkfe" = "xyes")
 AM_CONDITIONAL(DO_PERL, test "x$perl" = "xyes")
@@ -831,6 +838,7 @@ src/fe-text/Makefile
 src/fe-gtk/Makefile
 src/htm/Makefile
 src/htm/thememan
+osx/Info.plist
 plugins/Makefile
 plugins/python/Makefile
 plugins/perl/Makefile