summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 6 insertions, 35 deletions
diff --git a/configure.ac b/configure.ac
index ee0bf7e7..93802522 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,8 +41,7 @@ AH_VERBATIM([HEXCHATSHAREDIR],[#undef HEXCHATSHAREDIR])
 AH_VERBATIM([SOCKS],[#undef SOCKS])
 AH_VERBATIM([USE_MSPROXY],[#undef USE_MSPROXY])
 AH_VERBATIM([USE_LIBPROXY],[#undef USE_LIBPROXY])
-AH_VERBATIM([USE_GTKSPELL],[#undef USE_GTKSPELL])
-AH_VERBATIM([USE_LIBSEXY],[#undef USE_LIBSEXY])
+AH_VERBATIM([USE_SPELL],[#undef USE_SPELL])
 AH_VERBATIM([HAVE_ISO_CODES],[#undef HAVE_ISO_CODES])
 AH_VERBATIM([USE_LIBNOTIFY],[#undef USE_LIBNOTIFY])
 AH_VERBATIM([USE_LIBCANBERRA],[#undef USE_LIBCANBERRA])
@@ -145,8 +144,8 @@ AC_ARG_ENABLE(libcanberra,
 		libcanberra=$enableval, libcanberra=yes)
 
 AC_ARG_ENABLE(spell,
-	[AS_HELP_STRING([--enable-spell=type],[enable spelling type: none static libsexy gtkspell])],
-		  spell=$enableval, spell=libsexy)
+	[AS_HELP_STRING([--enable-spell],[enable spellcheck, (default: yes)])],
+		  spell=$enableval, spell=yes)
 
 AC_ARG_ENABLE(ntlm,
 	[AS_HELP_STRING([--enable-ntlm],[enable Microsoft\'s NTLM auth (libntlm) library support (default: no)])],
@@ -540,33 +539,10 @@ dnl *********************************************************************
 dnl ** SPELL ************************************************************
 dnl *********************************************************************
 
-if test "$spell" = "gtkspell" ; then
-	PKG_CHECK_MODULES(GTKSPELL, gtkspell-2.0 >= 2.0.2, [], [
-		spell=no
-	])
-	if test "$spell" != "no" ; then
-		GUI_LIBS="$GUI_LIBS $GTKSPELL_LIBS"
-		GUI_CFLAGS="$GUI_CFLAGS $GTKSPELL_CFLAGS"
-		AC_DEFINE(USE_GTKSPELL)
-	fi
-fi
-
-if test "$spell" = "libsexy" ; then
-	PKG_CHECK_MODULES([LIBSEXY], [libsexy >= 0.1.8], [
-		libsexy=yes
-		GUI_LIBS="$GUI_LIBS $LIBSEXY_LIBS"
-		GUI_CFLAGS="$GUI_CFLAGS $LIBSEXY_CFLAGS"
-		AC_DEFINE(USE_LIBSEXY)
-	], [
-		dnl use builtin static one
-		spell="static"
-	])
-fi
-
-if test "$spell" = "static" ; then
+if test "$spell" = "xyes" ; then
 	PKG_CHECK_MODULES(LIBXML2, libxml-2.0 >= 2.0.0, [
 	AC_DEFINE(HAVE_ISO_CODES)
-	AC_DEFINE(USE_LIBSEXY)
+	AC_DEFINE(USE_SPELL)
 	GUI_CFLAGS="$GUI_CFLAGS $LIBXML2_CFLAGS"
 	LIBS="$LIBS -lxml2"
 	], [
@@ -579,7 +555,7 @@ dnl ** CONDITIONALS *****************************************************
 dnl *********************************************************************
 
 AM_CONDITIONAL(USE_OPENSSL, test "x$openssl" = "xyes")
-AM_CONDITIONAL(USE_LIBSEXY, test "x$spell" = "xstatic")
+AM_CONDITIONAL(USE_SPELL, test "x$spell" = "xyes")
 AM_CONDITIONAL(USE_LIBNOTIFY, test "x$libnotify" = "xyes")
 AM_CONDITIONAL(USE_LIBCANBERRA, test "x$libcanberra" = "xyes")
 AM_CONDITIONAL(DO_TEXT, test "x$textfe" = "xyes")
@@ -865,10 +841,5 @@ if test "$gtkfe" = no; then
 	echo
 fi
 
-if test "$spell" = "gtkspell"; then
-	echo Warning: GTK SPELL is not the recommended spelling library.
-	echo
-fi
-
 echo configure complete, now type \'make\' and pray.
 echo