summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5f1c18a7..08fda30d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -579,6 +579,9 @@ dnl *********************************************************************
 CC_CHECK_FLAGS_APPEND([CFLAGS], [CFLAGS], [ \
 	-pipe \
 	-funsigned-char \
+	-fstack-protector-strong \
+	-fPIE \
+	-fPIC \
 	-Wall \
 	-Wextra \
 	-Wstrict-prototypes \
@@ -596,6 +599,12 @@ CC_CHECK_FLAGS_APPEND([CFLAGS], [CFLAGS], [ \
 	-Werror=pointer-arith \
 ])
 
+AX_APPEND_LINK_FLAGS([ \
+	-pie \
+	-Wl,-z,relro \
+	-Wl,-z,now \
+])
+
 dnl *********************************************************************
 dnl ** FUNCTIONS/LIBS/CFLAGS ********************************************
 dnl *********************************************************************