summary refs log tree commit diff stats
path: root/src/fe-gtk/Makefile.am
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2014-02-05 20:42:48 -0500
committerTingPing <tingping@tingping.se>2014-02-06 20:17:08 -0500
commit34cf164aa28c45c15ecf39b855f2de833a9b7c2d (patch)
tree059c5235b0974f2b8bbd2a6d5188425e882e6fd6 /src/fe-gtk/Makefile.am
parent5f7321280e2dfaa097fbd4855b547069ee96edc2 (diff)
Use a single marshal file for entire project
Diffstat (limited to 'src/fe-gtk/Makefile.am')
-rw-r--r--src/fe-gtk/Makefile.am14
1 files changed, 4 insertions, 10 deletions
diff --git a/src/fe-gtk/Makefile.am b/src/fe-gtk/Makefile.am
index 07f2ffc0..4ce02dbc 100644
--- a/src/fe-gtk/Makefile.am
+++ b/src/fe-gtk/Makefile.am
@@ -11,10 +11,10 @@ EXTRA_DIST = \
 	chanview-tree.c custom-list.h editlist.h fe-gtk.h fkeys.h gtkutil.h joind.h \
 	maingui.h menu.h notifygui.h palette.h pixmaps.h \
 	plugin-tray.h plugingui.c plugingui.h rawlog.h sexy-iso-codes.h \
-	sexy-spell-entry.h sexy-marshal.h textgui.h urlgrab.h userlistgui.h xtext.h \
+	sexy-spell-entry.h textgui.h urlgrab.h userlistgui.h xtext.h \
 	../../data/hexchat.gresource.xml
 
-BUILT_SOURCES = resources.c xtext_marshalers.h xtext_marshalers.c
+BUILT_SOURCES = resources.c
 
 CLEANFILES = $(BUILT_SOURCES)
 
@@ -29,14 +29,8 @@ endif
 hexchat_SOURCES = ascii.c banlist.c chanlist.c chanview.c custom-list.c \
 	dccgui.c editlist.c fe-gtk.c fkeys.c gtkutil.c ignoregui.c joind.c menu.c \
 	maingui.c notifygui.c palette.c pixmaps.c plugin-tray.c $(plugingui_c) \
-	rawlog.c resources.c servlistgui.c setup.c $(iso_codes_c) sexy-marshal.c \
-	sexy-spell-entry.c textgui.c urlgrab.c userlistgui.c xtext.c xtext_marshalers.c
+	rawlog.c resources.c servlistgui.c setup.c $(iso_codes_c) \
+	sexy-spell-entry.c textgui.c urlgrab.c userlistgui.c xtext.c
 
 resources.c: ../../data/hexchat.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=../../data --generate-dependencies ../../data/hexchat.gresource.xml)
 	$(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=../../data --generate-source $<
-
-xtext_marshalers.h: xtext_marshalers.list
-	$(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_xtext_marshal --header $(srcdir)/xtext_marshalers.list > $@
-
-xtext_marshalers.c: xtext_marshalers.list
-	$(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_xtext_marshal --body $(srcdir)/xtext_marshalers.list > $@