summary refs log tree commit diff stats
path: root/src/fe-gtk/Makefile.am
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2013-10-02 03:47:07 -0400
committerTingPing <tingping@tingping.se>2013-10-03 16:23:46 -0400
commit301e5d260d14738fba0d69e73129c52221a21839 (patch)
tree0f25c14ef03334e5649652bb26fb88f9f896152c /src/fe-gtk/Makefile.am
parentda680f1066c86b27e57b9b2a0b71046637c3b3a0 (diff)
More improvements to libsexy
- Add option for showing attributes in input
- Improve attribute parsing
- Fix detecting iso-codes on unix
- Improve getting default langs from $LANG
- Fix warnings
Diffstat (limited to 'src/fe-gtk/Makefile.am')
-rw-r--r--src/fe-gtk/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/fe-gtk/Makefile.am b/src/fe-gtk/Makefile.am
index 259d2c89..2e95232e 100644
--- a/src/fe-gtk/Makefile.am
+++ b/src/fe-gtk/Makefile.am
@@ -18,10 +18,14 @@ if DO_PLUGIN
 plugingui_c = plugingui.c
 endif
 
+if HAVE_ISO_CODES
+iso_codes_c = sexy-iso-codes.c
+endif
+
 hexchat_SOURCES = ascii.c banlist.c chanlist.c chanview.c custom-list.c \
 	dccgui.c editlist.c fe-gtk.c fkeys.c gtkutil.c ignoregui.c joind.c menu.c \
 	maingui.c notifygui.c palette.c pixmaps.c plugin-tray.c $(plugingui_c) \
-	rawlog.c resources.c servlistgui.c setup.c sexy-iso-codes.c sexy-marshal.c \
+	rawlog.c resources.c servlistgui.c setup.c $(iso_codes_c) sexy-marshal.c \
 	sexy-spell-entry.c textgui.c urlgrab.c userlistgui.c xtext.c
 
 resources.c: ../../data/hexchat.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=../../data --generate-dependencies ../../data/hexchat.gresource.xml)