summary refs log tree commit diff stats
path: root/src/fe-gtk/Makefile.am
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2015-10-16 17:25:01 +0200
committerRico Tzschichholz <ricotz@ubuntu.com>2015-10-16 17:25:01 +0200
commitb8e7dfa4baffa4378aee618d66ebfedaa285b235 (patch)
treedbe616d7b0792a003381a837cb6712b612a079fe /src/fe-gtk/Makefile.am
parent1d8dd50455248f61e01c3a1d1d3605dac5c4b107 (diff)
build: Let 'make dist' do a better job
Diffstat (limited to 'src/fe-gtk/Makefile.am')
-rw-r--r--src/fe-gtk/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/fe-gtk/Makefile.am b/src/fe-gtk/Makefile.am
index 778b6cfb..79cc2f32 100644
--- a/src/fe-gtk/Makefile.am
+++ b/src/fe-gtk/Makefile.am
@@ -7,15 +7,14 @@ bin_PROGRAMS = hexchat
 
 AM_CPPFLAGS = $(GUI_CFLAGS) -DLOCALEDIR=\"$(localedir)\"
 
-hexchat_LDADD = ../common/libhexchatcommon.a $(GUI_LIBS)
+hexchat_LDADD = $(top_builddir)/src/common/libhexchatcommon.a $(GUI_LIBS)
 
 EXTRA_DIST = \
 	ascii.h banlist.h chanlist.h chanview.h chanview-tabs.c \
 	chanview-tree.c custom-list.h editlist.h fe-gtk.h fkeys.h gtkutil.h joind.h \
 	maingui.h menu.h notifygui.h  notifications palette.h pixmaps.h plugin-notification.h \
-	plugin-tray.h plugingui.c plugingui.h rawlog.h sexy-iso-codes.h \
-	sexy-spell-entry.h textgui.h urlgrab.h userlistgui.h xtext.h \
-	../../data/hexchat.gresource.xml
+	plugin-tray.h plugingui.c plugingui.h rawlog.h servlistgui.h setup.h sexy-iso-codes.h \
+	sexy-spell-entry.h textgui.h urlgrab.h userlistgui.h xtext.h
 
 BUILT_SOURCES = resources.h resources.c
 
@@ -53,6 +52,8 @@ resources.h: $(top_srcdir)/data/hexchat.gresource.xml $(shell $(GLIB_COMPILE_RES
 resources.c: $(top_srcdir)/data/hexchat.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(top_srcdir)/data --generate-dependencies $(top_srcdir)/data/hexchat.gresource.xml)
 	$(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(top_srcdir)/data --generate-source --manual-register $<
 
+EXTRA_DIST += $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir=$(top_srcdir)/data $(top_srcdir)/data/hexchat.gresource.xml)
+
 if DO_STATIC_ANALYSIS
 analyze_plists = $(hexchat_SOURCES:%.c=%.plist)
 all-local: $(analyze_plists)