summary refs log tree commit diff stats
path: root/src/common/meson.build
diff options
context:
space:
mode:
authorMichael Catanzaro <mcatanzaro@redhat.com>2021-07-12 08:38:02 -0500
committerPatrick <tingping@tingping.se>2021-07-12 11:29:15 -0500
commit25440a07c3b421134b4376d7db3ee4b7ed57ad98 (patch)
tree73f110696622d7246bf3d64c4ab82f8f67bffe26 /src/common/meson.build
parent869a8d7ab335cf785e06450e4ab1ca02a9f5005f (diff)
Avoid direct use of libproxy
Since hexchat already depends on GLib, it's better to use GProxyResolver
instead. This might use libproxy, or not, as appropriate.

P.S. This removes a memory safety issue because proxy_list is allocated
using malloc(), not g_malloc(), and therefore using g_strfreev() is
incorrect. The proper way to free the proxy list returned by libproxy
is to use px_proxy_factory_free_proxies() (but nobody does that because
it was added in libproxy 0.4.16, which is somewhat recent).
Diffstat (limited to 'src/common/meson.build')
-rw-r--r--src/common/meson.build4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/common/meson.build b/src/common/meson.build
index 492227b2..09491e84 100644
--- a/src/common/meson.build
+++ b/src/common/meson.build
@@ -77,10 +77,6 @@ if get_option('with-ssl')
   common_deps += libssl_dep
 endif
 
-if get_option('with-libproxy')
-  common_deps += dependency('libproxy-1.0')
-endif
-
 if get_option('with-libcanberra')
   common_deps += dependency('libcanberra', version: '>= 0.22')
 endif