summary refs log tree commit diff stats
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorTingPing <tingping@fedoraproject.org>2014-06-14 12:07:47 -0400
committerTingPing <tingping@tingping.se>2014-12-30 06:35:42 -0500
commitfef580ed7faaba17e2c8fea504b8587850502220 (patch)
treef0a9be7563888a6cb321e167f700d2498bbd08ca /src/common/Makefile.am
parent3bb717a3b58240209df8275a9a64ee77516f531a (diff)
Rewrite identd
- Use gio (which is cross platform)
- Properly support multiple users
- Allow configuring port
- Allow other plugins overriding
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 0cbf650b..ea941671 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -26,6 +26,7 @@ EXTRA_DIST = \
 	notify.h \
 	outbound.h \
 	plugin.h \
+	plugin-identd.h \
 	plugin-timer.h \
 	proto-irc.h \
 	server.h \
@@ -60,7 +61,7 @@ noinst_PROGRAMS = make-te
 
 libhexchatcommon_a_SOURCES = cfgfiles.c chanopt.c ctcp.c dcc.c hexchat.c \
 	history.c ignore.c inbound.c marshal.c modes.c network.c notify.c \
-	outbound.c plugin.c plugin-timer.c proto-irc.c server.c servlist.c \
+	outbound.c plugin.c plugin-identd.c plugin-timer.c proto-irc.c server.c servlist.c \
 	$(ssl_c) text.c tree.c url.c userlist.c util.c
 libhexchatcommon_a_CFLAGS = $(LIBPROXY_CFLAGS)