summary refs log tree commit diff stats
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorhasufell <julian.ospald@googlemail.com>2013-03-31 17:01:56 +0200
committerhasufell <julian.ospald@googlemail.com>2013-03-31 17:01:56 +0200
commit83a59968171ae53a787108e03027799b6b03266b (patch)
tree81e88189aa1b0b657c942411a8027942b834c656 /src/common/Makefile.am
parent9ae63cf05d99865d03ddbcdf9f083d825fa212a4 (diff)
MAKE: install hexchat-plugin.h header if plugins are enabled
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 3be3b1c6..7b5612dd 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -52,6 +52,10 @@ libhexchatcommon_a_LIBADD =				\
 endif
 SUBDIRS = $(dbusdir) .
 
+if DO_PLUGIN
+include_HEADERS = hexchat-plugin.h
+endif
+
 libhexchatcommon_a_SOURCES = cfgfiles.c chanopt.c ctcp.c dcc.c hexchat.c \
 	history.c ignore.c inbound.c modes.c msproxy.c network.c notify.c \
 	outbound.c plugin.c plugin-timer.c proto-irc.c server.c servlist.c \