summary refs log tree commit diff stats
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2014-06-09 13:45:24 -0400
committerTingPing <tingping@tingping.se>2014-06-09 13:54:16 -0400
commit77d9d421fb14f99ee4624633535a762075c2a442 (patch)
treecb0ea926ef9080442efd03f987560867be6cac54 /src/common/Makefile.am
parent59f3a65911d5a6488f62c2a843a20b71a7fcef1f (diff)
Partial fix for out of source builds
Patch from LRN

Perl's makefile needs fixed and the relative include
of config.h needs removed from hexchat.h

Mentioned in #1018
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 8a177fa9..b5ffe1ce 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -69,14 +69,14 @@ libhexchatcommon_a_CFLAGS = $(LIBPROXY_CFLAGS)
 
 textenums.h: textevents.h
 
-textevents.h: textevents.in make-te
-	$(AM_V_GEN) ./make-te < textevents.in > textevents.h 2> textenums.h
+textevents.h: $(srcdir)/textevents.in make-te
+	$(AM_V_GEN) ./make-te < $< > $@ 2> textenums.h
 
-marshal.h: marshalers.list
-	$(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_hexchat_marshal --header $(srcdir)/marshalers.list > $@
+marshal.h: $(srcdir)/marshalers.list
+	$(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_hexchat_marshal --header $< > $@
 
-marshal.c: marshalers.list
-	$(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_hexchat_marshal --body $(srcdir)/marshalers.list > $@
+marshal.c: $(srcdir)/marshalers.list
+	$(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_hexchat_marshal --body $< > $@
 
 
 BUILT_SOURCES = textenums.h textevents.h marshal.c marshal.h