summary refs log tree commit diff stats
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2014-01-14 01:18:15 -0500
committerTingPing <tingping@tingping.se>2014-01-14 01:18:15 -0500
commitb2e3214d61c13cf6331e624c5a4b62cafb75cc2c (patch)
treeefa3b7c83ae0d77c98dbe9dfeaadadbc8d8afed0 /src/common/Makefile.am
parent0b52ec36762c0af7cad8f9b930f021565f3b56c7 (diff)
Clean up formatting during build
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index f4418a75..ca1eaba3 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -55,6 +55,8 @@ if DO_PLUGIN
 include_HEADERS = hexchat-plugin.h
 endif
 
+noinst_PROGRAMS = make-te
+
 libhexchatcommon_a_SOURCES = cfgfiles.c chanopt.c ctcp.c dcc.c hexchat.c \
 	history.c ignore.c inbound.c modes.c msproxy.c network.c notify.c \
 	outbound.c plugin.c plugin-timer.c proto-irc.c server.c servlist.c \
@@ -64,6 +66,6 @@ libhexchatcommon_a_CFLAGS = $(LIBPROXY_CFLAGS)
 textenums.h: textevents.h
 
 textevents.h: textevents.in make-te
-	./make-te < textevents.in > textevents.h 2> textenums.h
+	$(AM_V_GEN) ./make-te < textevents.in > textevents.h 2> textenums.h
 
 BUILT_SOURCES = textenums.h textevents.h