summary refs log tree commit diff stats
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2014-09-06 10:44:52 -0400
committerTingPing <tingping@tingping.se>2014-09-14 17:43:44 -0400
commit7a4a0243bd0a97abd0f231269c4265e0b1fa7712 (patch)
tree52f8813e5e557e8dc69108204f3d245706ea9d1e /src/common/Makefile.am
parente209e55e5921e9ccaf1f713aa5010ddf1cb1c2d8 (diff)
Fix out of source builds
Fixes #1018
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index b5ffe1ce..00fac49b 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -2,7 +2,7 @@
 
 noinst_LIBRARIES = libhexchatcommon.a
 
-AM_CPPFLAGS = $(COMMON_CFLAGS)
+AM_CPPFLAGS = $(COMMON_CFLAGS) -I$(top_srcdir)
 
 EXTRA_DIST = \
 	cfgfiles.h \
@@ -70,7 +70,7 @@ libhexchatcommon_a_CFLAGS = $(LIBPROXY_CFLAGS)
 textenums.h: textevents.h
 
 textevents.h: $(srcdir)/textevents.in make-te
-	$(AM_V_GEN) ./make-te < $< > $@ 2> textenums.h
+	$(AM_V_GEN) $(srcdir)/make-te < $< > $@ 2> textenums.h
 
 marshal.h: $(srcdir)/marshalers.list
 	$(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_hexchat_marshal --header $< > $@