summary refs log tree commit diff stats
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorberkeviktor@aol.com <berkeviktor@aol.com>2011-02-24 04:14:30 +0100
committerberkeviktor@aol.com <berkeviktor@aol.com>2011-02-24 04:14:30 +0100
commit4a6ceffb98a0b785494f680d3776c4bfc4052f9e (patch)
tree850703c1c841ccd99f58d0b06084615aaebe782c /src/common/Makefile.am
parentf16af8be941b596dedac3bf4e371ee2d21f4b598 (diff)
add xchat r1489
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
new file mode 100644
index 00000000..6a35da91
--- /dev/null
+++ b/src/common/Makefile.am
@@ -0,0 +1,61 @@
+## Process this file with automake to produce Makefile.in
+
+noinst_LIBRARIES = libxchatcommon.a
+
+INCLUDES = $(COMMON_CFLAGS)
+
+EXTRA_DIST = \
+	cfgfiles.h \
+	chanopt.h \
+	ctcp.h \
+	dcc.h \
+	fe.h \
+	history.h \
+	identd.c \
+	ignore.h \
+	inbound.h \
+	inet.h \
+	make-te.c \
+	modes.h \
+	msproxy.h \
+	network.h \
+	notify.h \
+	outbound.h \
+	plugin.h \
+	plugin-timer.h \
+	proto-irc.h \
+	server.h \
+	servlist.h \
+	ssl.h \
+	ssl.c	\
+	text.h \
+	textenums.h \
+	textevents.h \
+	textevents.in \
+	tree.h \
+	url.h \
+	userlist.h \
+	util.h \
+	xchat.h \
+	xchatc.h \
+	xchat-plugin.h
+
+if USE_OPENSSL
+ssl_c = ssl.c
+endif
+
+if USE_DBUS
+dbusdir = dbus
+libxchatcommon_a_LIBADD =				\
+	$(top_builddir)/src/common/dbus/dbus-*.$(OBJEXT)
+endif
+SUBDIRS = $(dbusdir) .
+
+libxchatcommon_a_SOURCES = cfgfiles.c chanopt.c ctcp.c dcc.c history.c ignore.c \
+	inbound.c modes.c msproxy.c network.c notify.c outbound.c \
+	plugin.c plugin-timer.c proto-irc.c server.c servlist.c $(ssl_c) \
+	text.c tree.c url.c userlist.c util.c xchat.c
+libxchatcommon_a_CFLAGS = $(LIBPROXY_CFLAGS)
+
+textevents: make-te
+	./make-te < textevents.in > textevents.h 2> textenums.h