summary refs log tree commit diff stats
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2014-02-05 20:42:48 -0500
committerTingPing <tingping@tingping.se>2014-02-06 20:17:08 -0500
commit34cf164aa28c45c15ecf39b855f2de833a9b7c2d (patch)
tree059c5235b0974f2b8bbd2a6d5188425e882e6fd6 /src/common/Makefile.am
parent5f7321280e2dfaa097fbd4855b547069ee96edc2 (diff)
Use a single marshal file for entire project
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 9c2d443e..8a177fa9 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -62,7 +62,7 @@ endif
 noinst_PROGRAMS = make-te
 
 libhexchatcommon_a_SOURCES = cfgfiles.c chanopt.c ctcp.c dcc.c hexchat.c \
-	history.c ignore.c inbound.c modes.c $(msproxy_c) network.c notify.c \
+	history.c ignore.c inbound.c marshal.c modes.c $(msproxy_c) network.c notify.c \
 	outbound.c plugin.c plugin-timer.c proto-irc.c server.c servlist.c \
 	$(ssl_c) text.c tree.c url.c userlist.c util.c
 libhexchatcommon_a_CFLAGS = $(LIBPROXY_CFLAGS)
@@ -72,4 +72,13 @@ textenums.h: textevents.h
 textevents.h: textevents.in make-te
 	$(AM_V_GEN) ./make-te < textevents.in > textevents.h 2> textenums.h
 
-BUILT_SOURCES = textenums.h textevents.h
+marshal.h: marshalers.list
+	$(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_hexchat_marshal --header $(srcdir)/marshalers.list > $@
+
+marshal.c: marshalers.list
+	$(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_hexchat_marshal --body $(srcdir)/marshalers.list > $@
+
+
+BUILT_SOURCES = textenums.h textevents.h marshal.c marshal.h
+
+CLEANFILES = $(BUILT_SOURCES)