summary refs log tree commit diff stats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPatrick Griffis <tingping@tingping.se>2016-12-13 16:12:03 -0500
committerPatrick Griffis <tingping@tingping.se>2017-06-13 23:54:51 -0400
commit628100c19f5d82747170acdf2917cba8c119ccbf (patch)
tree351a7e9714a1a58390ba349808df5703cef25c3e /src/Makefile.am
parent2edf50d4ddc61ce6f73bf02263c9bdd09632c66b (diff)
build: Replace Autotools with Meson
Quick rundown of benefits:

- Much faster:
  - Autotools (with autogen): 22 seconds
  - Meson: 7 seconds
  - Meson (with ccache): 2 seconds

- Simpler:
  - ~1000 lines smaller
  - Single simple language

- Potentially better Windows (Visual Studio) support

What is not done:

- Complete Windows support
- OSX support (easy)

Closes #2013
Closes #1937
Closes #1803
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 0 insertions, 17 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index d870aa0d..00000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,17 +0,0 @@
-## Process this file with automake to produce Makefile.in
-
-EXTRA_DIST = version-script
-
-if DO_TEXT
-text_fe = fe-text
-endif
-
-if DO_GTK
-gtk_fe = fe-gtk
-endif
-
-SUBDIRS = common $(gtk_fe) $(text_fe)
-
-if WITH_TM
-SUBDIRS += htm
-endif