summary refs log tree commit diff stats
path: root/share/icons/Makefile.am
diff options
context:
space:
mode:
authorRichardHitt <rbh00@netcom.com>2012-12-16 17:29:08 -0800
committerRichardHitt <rbh00@netcom.com>2012-12-16 17:29:08 -0800
commit925b45e8f0f3de9bf5072aad8240750c87cf03da (patch)
treebf2fbf2721bff2ed3ee288514736eac6306d301b /share/icons/Makefile.am
parentc6d955ade738815ec119ae76db32a3fcc1ac5d72 (diff)
Install hicolor svg; move the files Makefile.am to their subdirectories
Diffstat (limited to 'share/icons/Makefile.am')
-rw-r--r--share/icons/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/share/icons/Makefile.am b/share/icons/Makefile.am
new file mode 100644
index 00000000..dadaa67d
--- /dev/null
+++ b/share/icons/Makefile.am
@@ -0,0 +1,13 @@
+icon_DATA = ../../src/pixmaps/hexchat.png
+icondir = $(datadir)/pixmaps
+
+hicolor_DATA = hexchat.svg
+hicolordir = $(datadir)/icons/hicolor/scalable/apps
+
+UPDATE_ICON_CACHE = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook:
+	$(UPDATE_ICON_CACHE);
+
+uninstall-hook:
+	$(UPDATE_ICON_CACHE);