summary refs log tree commit diff stats
path: root/plugins/sysinfo/Makefile.am
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2015-02-14 13:35:02 -0500
committerTingPing <tingping@tingping.se>2015-02-21 20:09:15 -0500
commit5e3355a6c348b511c7b7a1f6dc89185726d566c5 (patch)
tree88183bc947205c24111589a7288b5f9f133a2875 /plugins/sysinfo/Makefile.am
parent363321dc33c8f390ff1d7109d632aaa53a82214e (diff)
Unify sysinfo plugins and add osx support
This does remove the net* commands from the
Unix version that may return at a later date
with OSX and Windows support.

This commit also makes numerious other changes
such as code cleanup, reformatting, etc.

Closes #829
Diffstat (limited to 'plugins/sysinfo/Makefile.am')
-rw-r--r--plugins/sysinfo/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/plugins/sysinfo/Makefile.am b/plugins/sysinfo/Makefile.am
index 4ac9c016..bd44a19d 100644
--- a/plugins/sysinfo/Makefile.am
+++ b/plugins/sysinfo/Makefile.am
@@ -1,7 +1,17 @@
 libdir = $(hexchatlibdir)
 
+sources = sysinfo.c format.c shared/df.c
+
+if PLATFORM_OSX
+sources += osx/backend.m
+else
+sources += unix/backend.c unix/match.c unix/parse.c unix/pci.c
+endif
+
+EXTRA_DIST = osx unix win32 shared format.h sysinfo.h sysinfo-backend.h
+
 lib_LTLIBRARIES = sysinfo.la
-sysinfo_la_SOURCES = match.c parse.c pci.c xsys.c
+sysinfo_la_SOURCES = $(sources)
 sysinfo_la_LDFLAGS = $(PLUGIN_LDFLAGS) -module
 sysinfo_la_LIBADD = $(LIBPCI_LIBS) $(GLIB_LIBS)
-sysinfo_la_CFLAGS = $(LIBPCI_CFLAGS) $(GLIB_CFLAGS) -I$(srcdir)/../../src/common
+AM_CPPFLAGS = $(LIBPCI_CFLAGS) $(GLIB_CFLAGS) -I$(top_srcdir)/src/common -I$(srcdir)/shared