summary refs log tree commit diff stats
path: root/plugins/perl/Makefile.am
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2014-12-28 06:08:20 -0500
committerTingPing <tingping@tingping.se>2014-12-28 06:47:07 -0500
commit3f855f07f5d2e9a08a586436719358c40a46f29d (patch)
tree12ffd1b49265e33c10149632a4cd17afb7fe994a /plugins/perl/Makefile.am
parent83032b1aa3c3e5910c5cfd3e0ea1d25827f56475 (diff)
Use glib for allocations in all plugins
Continuation of 83032b1aa
Diffstat (limited to 'plugins/perl/Makefile.am')
-rw-r--r--plugins/perl/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/plugins/perl/Makefile.am b/plugins/perl/Makefile.am
index 7e7bbe68..bec4e5ce 100644
--- a/plugins/perl/Makefile.am
+++ b/plugins/perl/Makefile.am
@@ -7,8 +7,8 @@ libdir = $(hexchatlibdir)
 lib_LTLIBRARIES = perl.la
 perl_la_SOURCES = perl.c
 perl_la_LDFLAGS = $(PERL_LDFLAGS) $(PLUGIN_LDFLAGS) -module
-perl_la_LIBADD = $(PERL_LIBS)
-perl_la_CFLAGS = $(PERL_CFLAGS) -I$(top_srcdir)/src/common
+perl_la_LIBADD = $(PERL_LIBS) $(GLIB_LIBS)
+perl_la_CFLAGS = $(PERL_CFLAGS) $(GLIB_CFLAGS) -I$(top_srcdir)/src/common
 
 BUILT_SOURCES = hexchat.pm.h irc.pm.h
 CLEANFILES = $(BUILT_SOURCES)