summary refs log tree commit diff stats
path: root/plugins/perl/Makefile.am
diff options
context:
space:
mode:
authorberkeviktor@aol.com <berkeviktor@aol.com>2011-02-24 04:14:30 +0100
committerberkeviktor@aol.com <berkeviktor@aol.com>2011-02-24 04:14:30 +0100
commit4a6ceffb98a0b785494f680d3776c4bfc4052f9e (patch)
tree850703c1c841ccd99f58d0b06084615aaebe782c /plugins/perl/Makefile.am
parentf16af8be941b596dedac3bf4e371ee2d21f4b598 (diff)
add xchat r1489
Diffstat (limited to 'plugins/perl/Makefile.am')
-rw-r--r--plugins/perl/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/plugins/perl/Makefile.am b/plugins/perl/Makefile.am
new file mode 100644
index 00000000..816ae67c
--- /dev/null
+++ b/plugins/perl/Makefile.am
@@ -0,0 +1,20 @@
+
+EXTRA_DIST=alt_completion.pl xchat2-perldocs.html xchat2-perl.html \
+	generate_header lib/Xchat.pm lib/Xchat/Embed.pm lib/Xchat/List/Network.pm \
+	lib/Xchat/List/Network/Entry.pm lib/Xchat/List/Network/AutoJoin.pm \
+	lib/IRC.pm
+
+libdir = $(xchatlibdir)/plugins
+
+lib_LTLIBRARIES = perl.la
+perl_la_SOURCES = perl.c
+perl_la_LDFLAGS = -avoid-version -module 
+perl_la_LIBADD = $(PERL_LDFLAGS)
+BUILT_SOURCES = xchat.pm.h irc.pm.h
+#CFLAGS = @CFLAGS@ -Wno-unused
+INCLUDES = $(PERL_CFLAGS) $(COMMON_CFLAGS) -I$(srcdir)/..
+CLEANFILES = xchat.pm.h irc.pm.h
+xchat.pm.h irc.pm.h: lib/Xchat.pm lib/Xchat/Embed.pm \
+	lib/Xchat/List/Network.pm lib/Xchat/List/Network/Entry.pm \
+	lib/Xchat/List/Network/AutoJoin.pm lib/IRC.pm
+	perl generate_header